Fitting a Howell TBI kit into a 1963 Rambler Classic

I bought this kit from fellow AMC-lister Russ (thanks continually!) who originally bought it from Howell for a project that ended up not materializing (my lab is filled with such things...). I had two cars that were candidates for it, my 1970 Hornet and my Classic wagon.

The Hornet is most ways was a better application -- it's got a 1983 Jeep 258 in it and already had the aluminum intake and all that -- but the wagon gets the sort of heavy use that TBI would benefit.

Earlier this year I converted the wagon back to gasoline; it had been propane-powered (single fuel) for 20 years. Due to changes in my life (no longer self-employed, mainly) scheduling and planning driving around fuel availability (pretty much restricted to weekday business hours) LP had become a limiting factor in use of the car.

Miracle of miracles, the local You-Pull-It, that rarely has anything AMC-related, had a 63 sedan with a good, rust-free! gas tank and all the necessary trivia to install it. Before installing it, I wisely added a fuel return line to the upper corner of the tank, where there was an oval cutout in the rear frame brace. I'd long ago removed the factory fuel line, so I ran a pair of 5/16" steel lines front to rear. To get it all running, I simply stuck an old Carter YF on the original iron one barrel manifold already on the car (where an Impco CA-125 had lived all this time) and drove it.

With a long trip coming up (Burning Man, in the Black Rock desert, 620 miles away) I figured now was the time to renovate the head. After 20 years, surprise, it needed a valve job. The old iron intake was leaking such that it would no longer idle well (#6 ran lean).

(These photos were taken before the rebuild; this is 20 years (200,000 miles) of wear on this motor. Not bad. That valve cover is as-removed; I did not even wipe it out. I did wipe off the piston crown with a rag to show the ".030" stamp.)

The head came off and went to the local machine shop for freshening. There was serious valve wear, no surprise at all. About half the valves were unusable. I had a spare ('64) head which became the donor for some used valves; the '64 head got cleaned up and crack-checked and is now on the shelf of good parts.

I built this motor in 1988; dead stock except flat-top 199 or 290 pistons so compression ratio is about 9.5:1. The crank at that time was perfect; sot it got polished and reinstalled as 0-under. It's run on synthetic oil the entire time, and LP fuel, and 20 years later, it's still clean inside, no ring wear.

HOWELL KIT -- PREPARATION

At this point the car was an ordinary gasoline-fueled, YF-carb'ed, 232 cubic inch six in front of a little Borg Warner automatic, about as close to stock as this car has ever been!

I had the Howell kit from Russ, and obtained a 1981-up aluminum intake manifold and matching exhaust from another AMC-lister, Joe. The used parts got hot-tanked at the local shop, and I scrounged up new fittings, cleaned up the old sensors, bought some fuel line (rubber and steel), before I started.

Since this is a 1970 motor in a 1963 car, there's no (legal) need for EGR, so I plugged it. The pintle hole is slightly smaller than the pilot hole for 3/8" pipe thread, so I threaded it and JB Weld'ed a brass plug in the hole. The other big vacuum line is for... vacuum wipers! This is probably the only EFI/vacuum wiper car around...

The Howell kit assumes you already have that intake on your engine. The late-model aluminum intake is a good investment -- it saves about 20 pounds of weight off the drivers side of the car, it's got a water jacket for consistent fuel delivery, and it's common and cheap. It's divorced from the exhaust manifold, so it runs cooler, and there's an electric heater for startup in cold weather (I leave this disconnected her e in Los Angeles). The exhaust manifold flows better (hell, you can tell just by looking!) and has the threaded hole for the oxygen sensor. Even if you want to use a carb, there's far more adapter for the Carter BBD pattern than there is for the old boat anchor manifold.

Old parts is old parts however -- things that allegedly "just bolt in" usually don't. The 1981 exhaust manifold outer mounting ears both hit the water pump (too wide) and wouldn't fit on the studs (too narrow). The former was solved by simply grinding metal off the ear, but the latter required nipping a bit out (to make a "C" shape). The manifold was flat, so if it warped, it did so perfectly in one plane. I rather think that AMC moved something. Weird, huh?

All of the AMC six manifolds are prone to leakage if not installed carefully, and the factory, and aftermarket, procedures for installation vary. I've tried them all, and they all eventually leak... though the aluminum manifolds don't seem to warp as much. But this time I used the larger steel/"asbestos" base gasket (shown above), left off the intake (thin, blue) gasket, and put a thin beat of Right Stuff (brand name) sealant on the intake manifold surface, AND the intake gasket surface. NO LEAKS. My guess is, it won't ever.

I took my time here. I had to buy a bunch of trivia to get it all right. Hose nipples for the water jacket, new water hose. My water pump was ancient, so I replaced it now with the radiator out anyways. I also replaced the just-about-leaking heater valve with a NAPA inline part and in general did a top-of-engine cleanup. This was a hidden $100 in hoses, clamps and stuff not in my copious junkboxes.

HOWELL KIT -- INSTALLATION

The Howell kit went in exactly as the instructions said -- no surprises! I had one problem on startup, see below. The wiring harness is designed for a Jeep, but since the engine pretty much determines the layout, it fit OK in the Classic wagon. The fuel pump relay was the only thing that wasn't close-to-perfect, I ended up with the fuse in a slightly inconvenient place, but reachable. The fuel pump relay lives right under the wiper motor. Eh.

I punched a 2" hole (I had a Greenlee that size) in th firewall below the heater box for the harness. To seal the hole I slit some fuel line to make the rubber bead, then used the Howell-provided grommet to fill that. Silicone (grey here) sealed it and provided physical strength. The computer mounted under the glovebox, because I have a lot of crap under the dash of my car, added by me over the last two decades. The computer is visible in the car, slightly, as is th ALDL connector. With some planning it could be better hidden, though there's not a lot of slack in the cable.

The MAP sensor needs to be above the throttle body with it's inlet pointing down. Well, it's like Rambler put that spring tower brace there back in '63 just waiting for this application.

Likely difficulties in non-Jeep applications

There are four things that would be the biggest problems in putting a Howell (or any other) EFI system into an older AMC car.

One, the fuel tank and fuel lines. EFI needs a fuel return line. Since I had my tank down for other reasons, I added a second line to it. After purging the tank completely dry (shop vac blowing air into the filler neck for an hour) I drilled a hole in an upper corner, and inserted a piece of steel line such that it reached the bottom of the tank, and soldered it in with a piece of brass for reinforcement. I probably shouldn't have bothered; each hole is a source for problems. I should have drilled the filler neck, fairly low down, and installed the return over there. You could wrestle the filler neck assembly out for drilling, and even weld a bung in. Clearly this needs to be done away from fuel...

Two, the fuel pump. The good news on TBI is the lower pressure, around 12 psi, a hell of a lot easier to plumb for than 45 psi port-injection systems. EFI fuel pumps however do not suck well; they need gravity feed from the gas tank, to push fuel up to the front of the car. Lucky for us, AMC/Ramblers have a fairly large open area up along side the "frame rail", right before the kickup to the rear wheel well. On a leaf spring car this is about where the front spring eye is; on a coil spring car it's a few cubic feet of convenient emptiness. I siliconed some military-surplus silicone foam to the frame under the pump; it prevents vibration (and associated failures) and it's absolutely silent. (The ugly black paint seals the ground connection; I sanded to shiny metal, crimped and soldered the ground wire, attached it with a #10 sheet metal screw, then soaked it in black paint against the elements of corrosion.)

I tucked the pump and filter up there. It's a few inches BELOW the fuel tank, and very well protected from stumps and rocks. The fuel lines run right past it (passenger side) so I cut the feed line there, curved it over to the pump, added another short section of pre-formed line and a coupler bent to fit also and coupled with rubber to the pump and filter. Came out very neat and pretty. I ran the power lead down the fuel line, with the fuse under the hood.

Howell's instructions said it was OK to put the pump in the front of the car, as low as possible; but if the pump momentarily lost suction on a steep hill, it wouldn't self-prime, and you would be dead in the road. I tend to do stupid things in this car like hill crawling desert mountains so that wasn't an option for me.

The fuel pump is susceptible to damage from crap in the tank. These are old cars -- the tanks are usually not clean! I put the small steel-canned filter (provided by Howell) in the line feeding the pump, and the big filter up front, in the hose from chassis to throttle body.

Three, the throttle linkage.

I never claimed to be a fully rational person, but I easily spent as much time on the throttle linkage as I did on the entire Howell installation. Rational or not, the feel of the gas pedal is a huge factor in my enjoyment of a car, I've come to realize. The original 1963 six linkage, modelled after the Nash system, is an old-fashioned floor-mounted pedal, a lever it rides on that passes through the firewall, which rotates a shaft. Said shaft runs directly to the butterfly valve in the carburetor. Pedal effort is zero, with about 1" of stroke, idle to wide open. This really matters to me as it turns out -- I dislike AMCs later cable throttles, they feel crunchy and cheap, with too much stiction and sloppiness.

There couldn't be a worse mis-match between car and throttle body than this.

So I made a linkage that translates the necessary force through two planes of rotation, while preserving stroke and also coupling to the old-fashioned transmission throttle position cable which requires a critical adjustment. I am quite proud of my throttle linkage, though no one else will really care. Throttle pedal force is only faintly more than the old Carter YF with longitudinal throttle rod.

Here's a movie of the linkage in action. As you can see, I am quite pleased with myself, uhuh.

As Mark points out, I managed to preserve the ability of a broken motor mount to jam the throttle open, a problem with the original design, but I don't care -- aesthetics matter, and I don't let my motor mounts get that bad.

Startup!

It took a three weekends to get the head off and rebuilt, back on, the new manifold in place and ready, and to get the Howell kit installed. Then another weekend (and more) to make the throttle linkage. And for me, since I had to convert this car to gasoline in the first place, a weekend of tank installation and related foolery.

Ignition on: the new CHECK ENGINE light indicates system normal. I primed the system as suggested, but slightly more paranoically. I pulled the fuel line from the throttle body, and pumped a pint or more of fuel into an old Gatorade jug, also ensuring that any grit and such in the hoses and such was clear.

Hose back on... one second of cranking, it starts and idles! Then chugs, black smoke, stinky of gas... crazy super rich! Bummer. Being a TBI virgin, I was baffled with where to start... after much foolishness of my own, a call to Howell got the suggestion to check fuel pressure and to check for pinched return lines, that sort of thing. I rigged up a pressure guage from junk hose and fittings and an oil pressure gauge (my old carb fuel gauge goes to 8 psi!). 50 psi! Oops!

I did the simple test, which is to pull the throttle body return hose off, stick it into a jug, then check pressure. 12 psi. Problem found -- return line plugged. Well I know my return line was working, back in the carburetor days, since I had a three-legged fuel filter on there. Inspection revealed that the hose that coupled the return line to the tank itself pinched where it had to make a "U" to get there. I shortened it to remove the pinch and it was clear again.

It now starts and idles and does not load up. A half hour in the driveway and it's warmed up and seems OK. No leaks, fuel or cooling system, which just got a big work-over at the same time. Test drive is fine. Throttle linkage feels fine. Easy highway drive is fine... 65mph is fine... success!

A day later, I pull the plugs, and they are a heading towards chocolatey colored -- too rich. No surprise there, as I know the maps are all wrong. A week of driving reveals mileage is about 15mpg, poor, was 18, 19 with the Carter YF, and should be 19, 20 with TBI I would guess.

So with Frank Swygert's suggestion I researched and made up a thing I consider to be a terrible kludge, an adjustable MAP sensor. Basically it's a finely adjustable voltage regulator to change the supply voltage to the MAP sensor, which in turn changes the signal that the computer gets. In short, lower supply voltage makes the computer think the air pressure is lower (higher vacuum) therefore less fuel demand. It's a bad way to tune the engine but since I have a week before a long trip...

It works surprisingly well. Mileage jumped to 17mpg and the plug color is about right. It clearly still needs re-mapping but for the short term, I can drive it without harm (to engine or wallet).
Tuning

(This is a placeholder; I am still in in the middle of tuning and making notes. I'll transfer it all here this (2008) winter.)

I'm half way through tuning the GM ECM now (November 2008). In short, it wasn't as painful as I thought; with the right gear in hand, it's easy if you are OK with a spreadsheet program.

After much research I bought a Moates' AutoPROM setup, about $329 with shipping. Exactly the right thing to do! I'm using TunerPro RT software (comes with) which pretty much required a dedicated Windows laptop. (I'm a linux user, and though TunerPro allegedly works under Wine, I had no joy.) But the software, and the AutoPROM box, does everything -- I read out the Howell EPROM for safekeeping and modification. Plugged into the EPROM socket, it emulates the EPROM (eg. you can make changes to the "EPROM" on the fly, while you drive). It will "burn" an "EPROM" image into a FLASH replacement EPROM chip. That needs an adapter -- but the AUtoPROM kit comes with everything.

I disconnected, forever, the adjustable MAP thing. No more!

The process was this. I yanked the ECM out, plucked out the EPROM (I had to saw it out of the chip carrier; Howell epoxies it in), stuck it into the AutoPROM and ripped a copy, saved it to disk for safe keeping. I made a copy to hack changes into.

First thing I did was tweak the BPC (Base Pulsewidth Constant) number which more or less encodes engine displacement. The Howell kit is for a 258, and I have a 232. The number was 187 (I think) and I ended up, experimentally, with 135. Everything had been crazy rich; now it was OK at high vacuum, still rich at low vacuum (open throttle).

Now I had a basis to begin tuning the fuel maps! But first some preliminaries.

My 1963 car has no EGR, no catalytic converter, no lock-up torque converter. I disabled all that stuff by setting values to 255MPH and such like values. Also disabled "highway mode" by having it start at 90MPH or whatever the maximum was. Easy enough.

To prevent Power Enrichment (the TBI equivalent of the accellerator pump) confusing things I set it to not start until 75% open throttle. This lets me do "partial throttle cruise" tuning without enrichment confusing things but still drive it on the highway. It also means the motor is weak, but that's only temporary.

The actual tuning process is iterative -- you gather data (see below) tweak the "EPROM", gather data -- lather rinse repeat until the errors are "small enough".

(Here is just raw note data, sorry. I'll round this out when I'm further along.)

Gather data, etc. Output as CSV.
Cat CSV's from one session into one big CSV.
Open CSV in open orfice.
Delete all rows with junk PROM IDs (ignition off),
  and any other unwanted data (eg. low coolant temp if tuning
  normal cruise, etc)

Hide or delete all columns except RPM, MAP Volts, Kpa, BLM, INT
Add column, "MAP KpA". Formula is = MAP V *51.8*0.369+10.45
Add column, "VE FIX". Formula is BLM/128.

Sort by: RPM then Kpa
Delete rows where INT != 128 or very close (BLM will be invalid).
Now view corresponds to fuel map layout

For each (RPM,KPA) table slot, find the closest data in the
spreadsheet, multiply VE in table by VE FIX.

VE FIX > 1 LEAN
       < 1 RICH
       = 1 PERFECT


NOTE: The sum of fuel map and additive map must be < 100!

Make sure the total of the two table is less that 100.